#23245 closed Bug (worksforme)

TypeError: 'set' object does not support indexing

Reported by: @… Owned by: SAMUEL BARFIELD III
Component: *.djangoproject.com Version:
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

How to Reproduce

While doing a GET operation on /watchlist, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'action': u'watch', 'realm': u'wiki', 'resid': u'TitleIndex'}

User agent: Mozilla/5.0 (PLAYSTATION 3 4.60) AppleWebKit/531.22.8 (KHTML, like Gecko)

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/home/trac/venv/lib/python2.6/site-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/home/trac/venv/lib/python2.6/site-packages/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/home/trac/venv/lib/python2.6/site-packages/tracwatchlist/plugin.py", line 524, in process_request
    req.redirect(req.href(realm,new_res[0]))
TypeError: 'set' object does not support indexing

Change History (3)

comment:1 Changed 13 months ago by bmispelon

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

How does this relate to Django?

comment:2 Changed 13 months ago by aaugustin

  • Resolution invalid deleted
  • Status changed from closed to new

We have the watch list plugin installed because someone requested it at some point.

Maybe we just need to update it.

comment:3 Changed 13 months ago by aaugustin

  • Cc SAMUEL BUSINESS OF INFORMATION removed
  • Component changed from Core (Management commands) to *.djangoproject.com
  • Has patch unset
  • Keywords SAMUEL SAMUEL BUSINESS OF INFORMATION removed
  • Resolution set to worksforme
  • Severity changed from Release blocker to Normal
  • Status changed from new to closed
  • Type changed from Uncategorized to Bug
  • UI/UX unset
  • Version 1.4 deleted

That said, the plugin appears to work just fine. I can't reproduce the issue.

Note: See TracTickets for help on using tickets.
Back to Top