Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#23158 closed Cleanup/optimization (duplicate)

Documentation pagination p.page_range

Reported by: Areski Belaid Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords: paginator
Cc: areski@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

The documentation on paginator have small error: https://docs.djangoproject.com/en/dev/topics/pagination/

Expected result:
p.page_range
[1, 2]

Current result:
p.page_range
xrange(1, 3)

Change History (5)

comment:2 Changed 4 years ago by Areski Belaid

Cc: areski@… added
Version: 1.6master

comment:3 Changed 4 years ago by Simon Charette

Triage Stage: UnreviewedAccepted

We might want to wait before making this documentation adjustment since this change (see #23088) caused some backward compatibility issue (see #23140).

comment:4 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Marking as a duplicate of #23140 which is tracking the outstanding issues with that.

comment:5 Changed 4 years ago by Collin Anderson

new ticket for possibly changing page_range to an iterator #23190

Note: See TracTickets for help on using tickets.
Back to Top