Opened 3 years ago

Closed 7 months ago

#23147 closed Bug (fixed)

Sliced for-update queries do not work on Oracle

Reported by: Shai Berger Owned by: felixxm
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords: oracle
Cc: Shai Berger Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Spin-off from #23061 (where the issue was with get queries, which have become sliced since #6785).

Change History (5)

comment:1 Changed 3 years ago by Shai Berger

I just closed #20647 as a duplicate of this -- that bug is a complaint about getting a string representation of for-update queries. It fails becuase the string-representation code uses slicing.

The test code attached to that ticket should be added when we solve this one, though.

comment:2 Changed 7 months ago by felixxm

Has patch: set
Owner: changed from Shai Berger to felixxm
Status: newassigned

comment:3 Changed 7 months ago by felixxm

Version: 1.6master

comment:4 Changed 7 months ago by Shai Berger

Cc: Shai Berger added
Triage Stage: AcceptedReady for checkin

LGTM.

comment:5 Changed 7 months ago by GitHub <noreply@…>

Resolution: fixed
Status: assignedclosed

In 695d4dd7:

Fixed #23147 -- Disabled a limit/offset on a query with select_for_update on Oracle.

Thanks Shai Berger and Tim Graham for the reviews.

Note: See TracTickets for help on using tickets.
Back to Top