#23124 closed Cleanup/optimization (fixed)

Add touch support for version chooser in documentation

Reported by: jarus Owned by: olasitarska
Component: *.djangoproject.com Version:
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

At the moment it isn't possible to switch between version in the Django documentation on touch devices. The chooser requires a mouse hober event which isn't provided by the most touch devices like iOS devices.

Change History (7)

comment:1 Changed 11 months ago by timo

  • Easy pickings unset
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 11 months ago by mardini

It works for me on Android (4.1.2, Chrome 33.0.1750.132) if I clicked the version number. So it seems the issue is in iOS only (I didn't try it myself).

comment:3 Changed 11 months ago by adambrenecki

I'm seeing the same bug in Safari on iOS 7.1 (11D167) and in IE on Windows Phone 8.1.

comment:4 Changed 11 months ago by adambrenecki

  • Owner changed from nobody to adambrenecki
  • Status changed from new to assigned

comment:5 Changed 10 months ago by evildmp

I've marked this ticket as especially suitable for people following the ​Don't be afraid to commit tutorial at the DjangoCon US 2014 sprints.

If you're tackling this ticket, please don't hesitate to ask me for guidance if you'd like any, either at the sprints themselves, or here or on the Django IRC channels, where I can be found as EvilDMP.

Note that the codebase for the Django Project website lives at https://github.com/django/djangoproject.com/

comment:6 Changed 10 months ago by olasitarska

  • Has patch set
  • Owner changed from adambrenecki to olasitarska

This task is assigned for 5 weeks, but patch is really simple, so I decided to fix this.

PR: https://github.com/django/djangoproject.com/pull/87

comment:7 Changed 10 months ago by Ola Sitarska <ola@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

In f882d8b0d63835e5451a464bdb0220cc888ba4d3/djangoproject.com:

Fixed #23124 -- Added touch support for version chooser in docs

Note: See TracTickets for help on using tickets.
Back to Top