#23052 closed Uncategorized (duplicate)

namespaced template loader

Reported by: rm_ Owned by: nobody
Component: Uncategorized Version: 1.6
Severity: Normal Keywords:
Cc: apollo13 Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I'd like to add support for loading app-namespaced template paths so that one can force the load of a template from a specific application.
The use case is to make the life of people doing admin themes easier. As of today it's not possible to extends the default admin theme but one have to duplicated all the templates, even when sometimes it's not needed. I'm biased as the current maintainer of django-admin-bootstrapped. I hope this would be useful for the popular grappelli and django-suit apps too.

Prior work:
https://github.com/Fantomas42/django-app-namespace-template-loader

Change History (1)

comment:1 Changed 10 months ago by apollo13

  • Cc apollo13 added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15053

Note: See TracTickets for help on using tickets.
Back to Top