Opened 8 months ago

Closed 8 months ago

#23033 closed Bug (duplicate)

Migrations depending on other app's __last__ migration fail

Reported by: lorinkoz@… Owned by: nobody
Component: Migrations Version: 1.7-rc-1
Severity: Release blocker Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

This happened to me when migrations have no been created at the same time in all applications. Also happened when using polymorphic models which made my custom user model depend on ContentType. In all cases making the migration *or* running them fails with "Dependency references nonexistent parent node ('<application>', 'last')"

Change History (1)

comment:1 Changed 8 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23008

Note: See TracTickets for help on using tickets.
Back to Top