Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#229 closed defect (duplicate)

Some images are linked-in externally in Admin interface

Reported by: deric Owned by: adrian
Component: contrib.admin Version:
Severity: trivial Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Index: django/conf/admin_media/js/SelectFilter2.js
===================================================================
--- django/conf/admin_media/js/SelectFilter2.js (revision 347)
+++ django/conf/admin_media/js/SelectFilter2.js (working copy)
@@ -51,7 +51,7 @@
         quickElement('h2', selector_available, 'Available ' + field_name);
         var filter_p = quickElement('p', selector_available, '');
         filter_p.className = 'selector-filter';
-        quickElement('img', filter_p, '', 'src', 'http://media.ljworld.com/img/admin/selector-search.gif');
+        quickElement('img', filter_p, '', 'src', '/media/img/admin/selector-search.gif');
         filter_p.appendChild(document.createTextNode(' '));
         var filter_input = quickElement('input', filter_p, '', 'type', 'text');
         filter_input.id = field_id + '_input';
@@ -73,7 +73,7 @@
         quickElement('h2', selector_chosen, 'Chosen ' + field_name);
         var selector_filter = quickElement('p', selector_chosen, 'Select your choice(s) and click ');
         selector_filter.className = 'selector-filter';
-        quickElement('img', selector_filter, '', 'src', 'http://media.ljworld.com/img/admin/selector-add.gif', 'alt', 'Add');
+        quickElement('img', selector_filter, '', 'src', '/media/img/admin/selector-add.gif', 'alt', 'Add');
         var to_box = quickElement('select', selector_chosen, '', 'id', field_id + '_to', 'multiple', 'multiple', 'size', from_box.size, 'name', from_box.getAttribute('name'));
         to_box.className = 'filtered';
         var clear_all = quickElement('a', selector_chosen, 'Clear all', 'href', 'javascript: (function() { SelectBox.move_all("' + field_id + '_to", "' + field_id + '_from");})()');
Index: django/conf/admin_media/js/admin/add_calendars.js
===================================================================
--- django/conf/admin_media/js/admin/add_calendars.js   (revision 347)
+++ django/conf/admin_media/js/admin/add_calendars.js   (working copy)
@@ -64,7 +64,7 @@
                                // <a href="javascript:AddCal.toggle()">Calendar</a>
                                var cal_link = document.createElement('a');
                                cal_link.setAttribute('href', 'javascript:AddCal.toggle(' + num + ');');
-                               quickElement('img', cal_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_calendar.gif', 'alt', 'Calendar');
+                               quickElement('img', cal_link, '', 'src', '/media/img/admin/icon_calendar.gif', 'alt', 'Calendar');
                                inp.parentNode.insertBefore(cal_link, inp.nextSibling);
 
                                // Markup looks like:
Index: django/conf/admin_media/js/admin/DateTimeShortcuts.js
===================================================================
--- django/conf/admin_media/js/admin/DateTimeShortcuts.js       (revision 347)
+++ django/conf/admin_media/js/admin/DateTimeShortcuts.js       (working copy)
@@ -36,7 +36,7 @@
         now_link.appendChild(document.createTextNode('Now'));
         var clock_link = document.createElement('a');
         clock_link.setAttribute('href', 'javascript:DateTimeShortcuts.openClock(' + num + ');');
-        quickElement('img', clock_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_clock.gif', 'alt', 'Clock');
+        quickElement('img', clock_link, '', 'src', '/media/img/admin/icon_clock.gif', 'alt', 'Clock');
         shortcuts_span.appendChild(document.createTextNode('\240'));
         shortcuts_span.appendChild(now_link);
         shortcuts_span.appendChild(document.createTextNode('\240|\240'));
@@ -106,7 +106,7 @@
         today_link.appendChild(document.createTextNode('Today'));
         var cal_link = document.createElement('a');
         cal_link.setAttribute('href', 'javascript:DateTimeShortcuts.openCalendar(' + num + ');');
-        quickElement('img', cal_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_calendar.gif', 'alt', 'Calendar');
+        quickElement('img', cal_link, '', 'src', '/media/img/admin/icon_calendar.gif', 'alt', 'Calendar');
         shortcuts_span.appendChild(document.createTextNode('\240'));
         shortcuts_span.appendChild(today_link);
         shortcuts_span.appendChild(document.createTextNode('\240|\240'));

Change History (1)

comment:1 Changed 10 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #49.

Note: See TracTickets for help on using tickets.
Back to Top