#22892 closed Bug (invalid)

ValueError: Cannot serialize function: lambda

Reported by: lorddaedra Owned by: andrewgodwin
Component: Migrations Version: 1.7-beta-2
Severity: Release blocker Keywords:
Cc: lorddaedra Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I can't make migrations. More info here: https://dpaste.de/J476 I think it's release blocker because of I can't use https://docs.djangoproject.com/en/dev/ref/models/fields/#default with lambda

May be you can reproduce this bug on more simple case (without custom field )...

I installed django yesterday with command
pip install git+https://github.com/django/django@stable/1.7.x
so it's latest Django 1.7.dev...

Change History (1)

comment:1 Changed 12 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

This is by design. There is some documentation about it already and #22351 suggests to enhance it.

Note: See TracTickets for help on using tickets.
Back to Top