Opened 6 years ago

Closed 6 years ago

#22599 closed Bug (invalid)

Recursive model relations admin interface

Reported by: ivicaned@… Owned by: nobody
Component: contrib.admin Version: 1.7-beta-2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

There is issue with admin in Django 1.7b3, when showing models that have recursive relationship to same model class. I think that the issue is related just to admin templates, because I am able to create this kind of models and they are inserted in db correctly, but on admin list page, they are not shown.
Let me know if you need some more details about this.
Also this is my first bug submission, so I appologize if I didn't follow bug submission guidelines.

class Category(models.Model):
    name = models.CharField(max_length=200)
    slug = models.SlugField()
    parent = models.ForeignKey('self', blank = True, null = True, related_name="children")
   
    def __str__(self):
        return self.name

Change History (1)

comment:1 Changed 6 years ago by ivicaned@…

Resolution: invalid
Status: newclosed

It was not bug, my fault, please ignore this ticket!

Note: See TracTickets for help on using tickets.
Back to Top