#22480 closed Uncategorized (invalid)

"django-admin.py dumpdata" - unable to serialize

Reported by: yn Owned by: nobody
Component: Core (Serialization) Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I encountered an error in

django-admin.py dumpdata

https://docs.djangoproject.com/en/1.6/ref/django-admin/#django-admin-dumpdata

This command should print the serialized dump to stdout. And it's work fine

I need to redirect stdout to file

But

django-admin.py dumpdata > data.json

generates the error "Command error - unable to serialize"

Django 1.6.2

Python 3.3

Windows 7 home 64b

Attachments (2)

CWindowssystem32cmd.exe_2014-04-21_14-27-23.png (119.6 KB) - added by yn 11 months ago.
manage_dump_traceback.png (74.5 KB) - added by yn 11 months ago.
manage.py dumpdata --traceback > data.json

Download all attachments as: .zip

Change History (7)

comment:1 follow-up: Changed 11 months ago by timshaffer

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Do you get any extra output if you run it with traceback?

manage.py dumpdata --traceback > data.json

Changed 11 months ago by yn

manage.py dumpdata --traceback > data.json

comment:2 in reply to: ↑ 1 Changed 11 months ago by yn

Replying to timshaffer:

Do you get any extra output if you run it with traceback?

manage.py dumpdata --traceback > data.json

See the new attach.

Without > file.json it's work fine.

Last edited 11 months ago by yn (previous) (diff)

comment:3 follow-up: Changed 11 months ago by timo

I have been unable to reproduce this error, but could you try python manage.py ...?

comment:4 in reply to: ↑ 3 Changed 11 months ago by yn

Replying to timo:

I have been unable to reproduce this error, but could you try python manage.py ...?

Yes, it working now

python manage.py dumpdata > data.json

comment:5 Changed 11 months ago by timo

  • Component changed from Uncategorized to Core (Serialization)
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top