Opened 2 years ago

Closed 2 years ago

#22418 closed Bug (duplicate)

Remove app_name attribute of AdminSite

Reported by: Vlastimil Zíma Owned by: nobody
Component: contrib.admin Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Since the admin application uses single application namespace admin which is hardcoded it is ridiculous to have an option which can alter this value.

This attribute causes confusion between developers, see #19002 #19554.

I attach patch which shows failures in admin_views tests in Django 1.6.

Attachments (1)

0001-Show-app_name-error-in-admin.patch (3.2 KB) - added by Vlastimil Zíma 2 years ago.
Tests for custom app_name

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by Vlastimil Zíma

Tests for custom app_name

comment:1 Changed 2 years ago by Tim Graham

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: duplicate
Status: newclosed

Duplicate of #21132, feel free to leave your thoughts there.

Note: See TracTickets for help on using tickets.
Back to Top