Opened 4 years ago

Closed 4 years ago

#22389 closed Bug (duplicate)

contrib.formtools show errors while running test suite on windows

Reported by: ANUBHAV JOSHI Owned by: nobody
Component: contrib.formtools Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When running the test suite on windows. We get some errors:
One can see the traceback: https://gist.github.com/coder9042/9996028

Change History (3)

comment:1 Changed 4 years ago by Tim Graham

Component: Testing frameworkcontrib.formtools
Triage Stage: UnreviewedAccepted

I can reproduce these errors.

comment:2 Changed 4 years ago by ANUBHAV JOSHI

I tried to find the reason behind the error, tried to fix it but could not uptil now.
I have some observations, they may/may not be useful:

  • I tried to print type of file being opened and object created and found only UploadedFile and InMemoryUploadedFile
  • The path that is shown in the traceback that could not be removed is no longer there after the suite has run.
  • When I just make #files/storage.pyL260 this into docstring or in other words remove it then my tests added in the commit fa8b47 fail, which seems quite strange as temporary files do not exist before deletion as shown by failure of tests.

comment:3 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #22772 which has been fixed.

Note: See TracTickets for help on using tickets.
Back to Top