Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2237 closed defect (duplicate)

Setting TEMPLATE_STRING_IF_INVALID causes admin page headline to vanish

Reported by: russellm Owned by: adrian
Component: contrib.admin Version: master
Severity: normal Keywords: admin TEMPLATE_STRING_IF_INVALID
Cc: farcaller@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Vladimir Pouzanov <farcaller@…> reports:

When I add

TEMPLATE_STRING_IF_INVALID = 'INVALID'

to my config, first page of admin (i.e. http://127.0.0.1:8000/admin/) is rendered without 'Django administration' headline.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by russellm

A few more details: The headline is missing from the main page; if you follow a link to a model, the headline comes back, but the column titles for object instances are rendered as the text "INVALID" (or whatever you set TEMPLATE_STRING_IF_INVALID to be).

comment:2 Changed 8 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1338.

comment:3 Changed 8 years ago by russellm

(In [3268]) Fixes #1338, Refs #1400, #2237 -- Modified variable resolution to allow template 'if' statements to work if TEMPLATE_STRING_IF_INVALID is set. Modified unit tests to force the use of this variable, so that returning isn't confused with an actual failure.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.