#22345 closed Uncategorized (duplicate)

API documentation should show package name

Reported by: poswald Owned by: nobody
Component: Documentation Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Throughout the API, it can be very difficult to know which package you need to import to get access to a class or function. Often this is encoded into the permalink but not visible on the page. For example the anchor is:

https://docs.djangoproject.com/en/dev/ref/forms/fields/#django.forms.Field

but the class is described as:

class Field(kwargs)

I think it would be best to list it as:

class django.forms.Field(kwargs)

Or at least put the package name as a section header. I imagine there's a way to make the documentation do this site-wide or at least for the API section?

Change History (1)

comment:1 Changed 15 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15396

Note: See TracTickets for help on using tickets.
Back to Top