Opened 3 years ago

Closed 3 years ago

#22333 closed Bug (duplicate)

as_p() produces invalid HTML when form contains RadioSelect widget

Reported by: artem.rizhov@… Owned by: nobody
Component: Forms Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

as_p() produces invalid HTML when form contains RadioSelect widget. <UL> can not be placed inside of <P>. This breaks markup. Both Firefox and Chrome close <P> automatically before <UL>. This also causes that closing tag </P> appears without opening one.

Change History (1)

comment:1 Changed 3 years ago by Mark Lavin

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: duplicate
Status: newclosed

This is a duplicate of #6388.

Note: See TracTickets for help on using tickets.
Back to Top