Opened 16 months ago

Closed 14 months ago

Last modified 14 months ago

#22328 closed New feature (fixed)

Add --exclude option to compilemessages

Reported by: infraredgirl Owned by: infraredgirl
Component: Core (Management commands) Version: master
Severity: Normal Keywords:
Cc: loic@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Add an option to the compilemessages management command, to enable exclusion of specific locales.

E.g:

python manage.py compilemessages --exclude fr --exclude es

would compile all the languages except for French and Spanish.

Change History (7)

comment:1 Changed 16 months ago by infraredgirl

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Status changed from new to assigned

comment:2 Changed 16 months ago by infraredgirl

  • Version changed from 1.6 to master

comment:4 Changed 16 months ago by claudep

  • Triage Stage changed from Unreviewed to Accepted

comment:5 Changed 14 months ago by loic84

  • Cc loic@… added
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 14 months ago by loic84

The -e shorthand introduced for makemessages --exclude caused a regression due to a conflict with the existing makemessages --extensions.

Refs https://groups.google.com/d/topic/django-developers/a7jksjMWmbY/discussion.

Backward compatible options are:

  1. no shorthand at all for the two commands.
  2. no shorthand for makemessages.
  3. change both shorthands to -x (eXclude).

I went with option 3 in https://github.com/django/django/pull/2621, feedback welcome.

comment:7 Changed 14 months ago by Loic Bistuer <loic.bistuer@…>

In d1799233f46c39379fe429a4ece128d96b128006:

Fixed clash caused by the newly introduced -e shorthand for makemessages --exclude.

This fixes a regression caused by 0707b82. Refs #22328.

Note: See TracTickets for help on using tickets.
Back to Top