#22320 closed New feature (duplicate)

assertNumQueries should capture call stacks

Reported by: boxm Owned by: nobody
Component: Testing framework Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


When an assertNumQueries assertion fails there are two things that are very helpful in diagnosing the issue: the SQL calls generated, and what caused them. assertNumQueries does a good job with the former, but provides no help with the latter.

If the CursorDebugWrapper kept track of the traceback for each query, it would be simple to see what had caused any unexpected queries.

Change History (3)

comment:1 Changed 21 months ago by boxm

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 21 months ago by boxm

  • Version changed from 1.6 to master

comment:3 Changed 21 months ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9363

Note: See TracTickets for help on using tickets.
Back to Top