#22143 closed Uncategorized (duplicate)

Default bounds checking for Integer fields.

Reported by: dimyur27@… Owned by: nobody
Component: Forms Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: yes Patch needs improvement: yes
Easy pickings: no UI/UX: no

Description

I think that informing people that certain input values are safe is not enough.
https://docs.djangoproject.com/en/dev/ref/models/fields/#django.db.models.IntegerField
When you create a ModelForm with minimal code, its integer fields do not check if the input violates the boundaries.
So when the end-user inputs large integer, he just gets Server Error (500)
Exception DataError: *int out of range. is generated.

Change History (4)

comment:1 Changed 18 months ago by anonymous

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:3 Changed 18 months ago by gregchapple

  • Needs tests set
  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 18 months ago by timo

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12030

Note: See TracTickets for help on using tickets.
Back to Top