Code

Opened 2 months ago

Closed 2 months ago

#21959 closed Bug (fixed)

widthratio templatetag fails to handle NaN ratio

Reported by: rmoe Owned by: Aymeric Augustin <aymeric.augustin@…>
Component: Template system Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When value or max_value are float('inf') or float('nan') the ratio calculation can raise an exception.

Attachments (1)

defaulttags.diff (1.5 KB) - added by rmoe 2 months ago.

Download all attachments as: .zip

Change History (5)

Changed 2 months ago by rmoe

comment:1 Changed 2 months ago by jwiel86

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Hi, thanks for reporting. Do you mind giving more information on how to reproduce this exception so a newbie could partake? Thanks!

comment:2 Changed 2 months ago by rmoe

You just need to call widthratio with float('inf') as both the value and max_value. like so:

{% widthratio 'inf' 'inf' 100 %}

Which will raise this (because ratio is NaN and can't be converted to an integer):

ValueError at /project/
cannot convert float NaN to integer

Request Method:	GET
Django Version:	1.5.4
Exception Type:	ValueError
Exception Value: cannot convert float NaN to integer
Exception Location: /usr/lib/python2.7/dist-packages/django/template/defaulttags.py in render, line 467

For some additional context, this was encountered in the Horizon component of the OpenStack project. https://github.com/openstack/horizon/blob/master/horizon/templates/horizon/common/_limit_summary.html#L6

When disabling quotas in the Nova component (the data it's trying to build the pie charts for) all quota values are set to -1 which equates to an infinite quota. So in the case where quotas are disabled usage.limits.totalInstancesUsed and usage.limits.maxTotalInstances are both float('inf'). This breaks the project overview page because of the exception raised from the widthratio templatetag.

comment:3 Changed 2 months ago by aaugustin

  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 2 months ago by Aymeric Augustin <aymeric.augustin@…>

  • Owner set to Aymeric Augustin <aymeric.augustin@…>
  • Resolution set to fixed
  • Status changed from new to closed

In 07ae47f7f8b5d5f80238ea3018163cad12917852:

Fixed #21959 -- Handled Inf/NaN in widthratio tag.

Thanks rmoe for the report and the patch.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.