Opened 3 years ago

Closed 3 years ago

#21909 closed Bug (invalid)

manage.py sql/migrate fails to product SQL for geometry fields

Reported by: Akis Kesoglou Owned by: nobody
Component: GIS Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hello,

assume the following model:

from django.contrib.gis.db import models


class Location(models.Model):
    point = models.PointField(srid=4326)
    objects = models.GeoManager()

running ./manage.py sql testgis produces the following output:

BEGIN;
CREATE TABLE "testgis_location" (
    "id" integer NOT NULL PRIMARY KEY AUTOINCREMENT
)
;

COMMIT;

I have attached a test project.

Attachments (1)

testgis.zip (4.4 KB) - added by Akis Kesoglou 3 years ago.
Test project

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by Akis Kesoglou

Attachment: testgis.zip added

Test project

comment:1 Changed 3 years ago by Akis Kesoglou

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: invalid
Status: newclosed

I'm marking this ticket as invalid, since the SQL for the geometry fields is correctly produced by sqlall, and also by migrate.

While creating a test project yesterday, migrate somehow failed to create geometry fields and a quick investigation led me to opening this ticket. I'm closing it since i cannot reproduce it anymore.

Note: See TracTickets for help on using tickets.
Back to Top