#21857 closed Uncategorized (duplicate)

Text "Hold down "Control", or "Command" on a Mac, to select more than one." in 1.6 even though it's indicated Django does not do this anymore

Reported by: lee@… Owned by: nobody
Component: Uncategorized Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I just upgraded my app to 1.6 and am seeing instances of "Hold down "Control", or "Command" on a Mac, to select more than one." everywhere I use a a ModelMultipleChoiceField, even though the docs explicitly say this text isn't supposed to be added anymore. I also see code to do this, here:

https://github.com/django/django/blob/stable/1.6.x/django/forms/models.py#L1166-L1168

The release notes read:

HTML rendering of model form fields corresponding to ManyToManyField ORM model fields used to get the hard-coded sentence

Hold down “Control”, or “Command” on a Mac, to select more than one.
(or its translation to the active locale) imposed as the help legend shown along them if neither model nor form help_text attribute was specified by the user (or appended to, if help_text was provided.)

This happened always, possibly even with form fields implementing user interactions that don’t involve a keyboard and/or a mouse and was handled at the model field layer.

Starting with Django 1.6 this doesn’t happen anymore.

Change History (1)

comment:1 Changed 15 months ago by carljm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21858

Note: See TracTickets for help on using tickets.
Back to Top