#21835 closed Cleanup/optimization (duplicate)

Remove contrib.admin dependency in contrib.contenttypes

Reported by: russellm Owned by: nobody
Component: contrib.contenttypes Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If you try to use a GenericForeignKey in your project, you gain a dependency on contrib.admin.

This is a particular problem with the combined power of the checks framework and app-loading, because if contrib.admin isn't in your project, you'll get errors.

Change History (2)

comment:1 Changed 15 months ago by russellm

See #20915 for a related problem with auth and admin.

comment:2 Changed 15 months ago by carljm

  • Resolution set to duplicate
  • Status changed from new to closed

I think this is actually a dupe of #19774.

Note: See TracTickets for help on using tickets.
Back to Top