Opened 3 years ago

Closed 3 years ago

#21759 closed Uncategorized (duplicate)

admindocs doesn't restructuredtext-ify model docstrings

Reported by: chris@… Owned by: nobody
Component: Uncategorized Version: 1.5
Severity: Normal Keywords: admindocs
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

e.g.

class Bar:
  pass

class Foo:
  """
  Refers to :model:`app.Bar`.
  """
  pass

does not create a link to the Bar model. The documentation doesn't say anything about this; it looks like the raw docstring from model.__doc__ is passed straight to the template.

Change History (1)

comment:1 Changed 3 years ago by Tim Graham

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: duplicate
Status: newclosed

Duplicate of #5405 -- feel free to work on polishing the pull request there if you'd like to help out.

Note: See TracTickets for help on using tickets.
Back to Top