Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2153 closed defect (fixed) fails to render

Reported by: anonymous Owned by: adrian
Component: Core (Other) Version:
Severity: trivial Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Sometimes when django is unable to find the correct location for an error,
it just dumps a stack trace instead of showing the more informative debug page.

The problem is in views/, setting the lastframe to the last element of the frames list,
which happens to be empty if no frame could be found.

A trivial patch solving the problem is attached.

Attachments (1)

debug_patch (557 bytes) - added by anonymous 9 years ago.
[patch] remove possible rendering failure in

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by anonymous

[patch] remove possible rendering failure in

comment:1 Changed 9 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [3127]) Fixed #2153 -- display debugging template even if no stack frame is found.

Note: See TracTickets for help on using tickets.
Back to Top