Opened 9 years ago

Closed 7 years ago

#2151 closed enhancement (duplicate)

Support app renaming in INSTALLED_APPS

Reported by: mattmcc Owned by: anonymous
Component: Core (Other) Version:
Severity: normal Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Reference thread: http://groups.google.com/group/django-developers/browse_thread/thread/7197d27127494ee2/df18ee9b91ba383c

Several implementations were proposed, the one that seems to be most favored is:

INSTALLED_APPS = (
    'foo.bar.baz',
    ('foo.quux.baz', 'baz2')
)

Change History (5)

comment:1 Changed 8 years ago by SmileyChris

  • Triage Stage changed from Unreviewed to Accepted

Need a decision on which way to go with this.

I agree that it's slightly obscure having ('baz', 'baz2') (which is the label again?) but also that 'baz as baz2' is a bit "code-in-string"y

Personally I slightly prefer the '... as ...' option.

comment:2 Changed 8 years ago by SmileyChris

  • Triage Stage changed from Accepted to Design decision needed

comment:3 Changed 8 years ago by Rick <Rick.van.Hattem@…>

Personally I prefer ('foo.bar.spam.eggs', 'foobar') above the 'foo.bar.spam.eggs as foobar', besides being slower (marginally ofcourse) it just doesn't look as good either.

I admit it's a little more obscure, but with a nice example it should be clear enough for everyone.

comment:4 Changed 7 years ago by sneeu

  • Owner changed from nobody to anonymous
  • Status changed from new to assigned

comment:5 Changed 7 years ago by jkocherhans

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #3591. There's a patch there.

Note: See TracTickets for help on using tickets.
Back to Top