Opened 3 years ago

Closed 9 months ago

#21501 closed New feature (duplicate)

BaseFormSet's empty_form isn't as extendable as _construct_form()

Reported by: Keryn Knight <django@…> Owned by: nobody
Component: Forms Version: master
Severity: Normal Keywords:
Cc: berker.peksag@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


It is possible to wedge extra kwargs into each form in a Formset by doing something like:

class MyFormSet(BaseFormSet):
    def _construct_form(self, i, **kwargs):
        kwargs['extrafield'] = 1
        return super(MyFormSet, self)._construct_form(i, **kwargs)

which is useful for forms wanting to require additional arguments - for inlines wanting to act on values in an existing parent instance, for example.

However, the kwarg can't be required, because of the empty_form property, which doesn't have any way of marshall extra kwargs to the form (though it can add fields), as such, the empty_form definition must be copy-pasted entirely, which isn't ideal if the definition upstream (ie: in Django) shifts over time.

A private api method:

def _get_empty_form_kwargs(self):
    return {}

which could be dictionary expanded into the empty_form would allow for passing required arguments in [I believe] a backwards compatible way, while allowing userland code to replace less of the core FormSet functionality.

The final empty_form might be something like:

    def empty_form(self):
        form = self.form(
        self.add_fields(form, None)
        return form

Change History (2)

comment:1 Changed 3 years ago by Tim Graham

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedAccepted

comment:2 Changed 9 months ago by Berker Peksag

Cc: berker.peksag@… added
Resolution: duplicate
Status: newclosed

This looks like a duplicate of #18166. A new get_form_kwargs method has been added in 238e2ac3690755d0e6c2dfca815e2b6f84a47f6e.

Note: See TracTickets for help on using tickets.
Back to Top