Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#21456 closed Bug (duplicate)

Docs typo

Reported by: icedream91@… Owned by: nobody
Component: Documentation Version: 1.6
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

In page https://docs.djangoproject.com/en/1.6/topics/db/managers/, there is a wrong single quote sign before "base QuerySet returns all objects in the system", it should be " ' ".

Change History (5)

comment:1 Changed 16 months ago by bmispelon

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Hi,

I don't see the typo you're talking about.

The single quote is part of the possessive form in English ('s): https://en.wikipedia.org/wiki/English_possessive.

I'll close this ticket as invalid. Feel free to reopen it if I've misunderstood your report.

Thanks.

comment:2 Changed 16 months ago by icedream91@…

  • Resolution invalid deleted
  • Status changed from closed to new

Are you using Firefox? There seems no problems when using Firefox, try Chrome. Or just see the PDF docs, it's clearer.

You will find that the single quote sign in sentence "A Manager‘s base QuerySet returns all objects in the system" is not as same as in other sentences like "you’d use OpinionPoll.objects.with_counts() to return that list of OpinionPoll objects with num_responses attributes"(the second sentence is just above the first sentence).

You can find many same typos in PDF version of document, just search the single quote sign in sentence "A Manager‘s base QuerySet returns all objects in the system" in page 119.

Not all single quote signs are wrong, for the single quote sign in sentence "you’ll be logged in as the attacker and might inadvertently enter your sensitive personal data (e.g. credit card info) into the attackers account." in page 203 in PDF docs is right.

By the way, the single quote sign in sentence "*.example.com‘" in page 203 in PDF docs may be reduntant.

comment:3 follow-up: Changed 16 months ago by bmispelon

  • Resolution set to duplicate
  • Status changed from new to closed

I see what you mean now.

This ticket is a duplicate of #20852 which was only fixed in the master branch. I'll check with Tim Graham if it'd be possible to backport the fix to the 1.6 branch.

In the meantime, let's keep the discussion on the original ticket.

Thanks.

comment:4 in reply to: ↑ 3 Changed 16 months ago by icedream91@…

Is the grave accent in sentence "on *.example.com`" in page https://docs.djangoproject.com/en/1.6/topics/http/sessions/ reduntant?

comment:5 Changed 16 months ago by timo

Fixed the *.example.com typo in 9348fc5628ccbbe156e9523b5eb8ba3ce783166e, thanks.

Note: See TracTickets for help on using tickets.
Back to Top