#21449 closed Bug (duplicate)

Test Client login does not work without django.contrib.sessions in INSTALLED_APPS

Reported by: GunnarScherf Owned by: nobody
Component: Testing framework Version: 1.6
Severity: Normal Keywords: test client login cookie session
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The documentation on https://docs.djangoproject.com/en/1.6/topics/http/sessions/ says in a note:

When using cookies-based sessions django.contrib.sessions can be removed from INSTALLED_APPS setting because ...

But without django.contrib.sessions in INSTALLED_APPS the login of the Test Client does not work because of:

    if user and user.is_active \
          and 'django.contrib.sessions' in settings.INSTALLED_APPS:

Change History (1)

comment:1 Changed 18 months ago by KJ

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from Uncategorized to Bug

This looks like a duplicate of #7836. See also #16605.

Note: See TracTickets for help on using tickets.
Back to Top