#21444 closed Bug (fixed)

Contact the DSF page returns an error when the message is submitted

Reported by: EvilDMP Owned by: nobody
Component: *.djangoproject.com Version:
Severity: Normal Keywords:
Cc: bmispelon Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

https://www.djangoproject.com/contact/foundation/

    Page unavailable
    We're sorry, but the requested page is currently unavailable.

    We're messing around with things internally, and the server had a bit of a hiccup.

Change History (3)

comment:1 Changed 21 months ago by bmispelon

  • Cc bmispelon added

Hi,

I can't reproduce this issue.
I've tried both on my local install and at https://www.djangoproject.com/contact/foundation/ and both worked correctly.

Do you hit the issue consistently or was it just a one-time thing? Was there anything note-worthy about the message (non-ascii characters in the body, long message, ...)?

comment:2 Changed 21 months ago by EvilDMP

How odd. I tried it twice, with the same result. The message was 2232 chars, and the only possibly unusual characters were £ and € signs.

Can you test those on your local installation?

comment:3 Changed 21 months ago by Baptiste Mispelon <bmispelon@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 81ace9051b25cbda32507b244d2dc07aeb633813/djangoproject.com:

Fixed #21444 -- Fixed UnicodeEncodeError when passing non-ascii chars to ContactForm.

Note: See TracTickets for help on using tickets.
Back to Top