#21366 closed Bug (fixed)

Regression in query join promotion logic

Reported by: timo Owned by: akaariai
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

(master only) I think there's a regression in the following commit - test case that passes before the commit attached.

https://github.com/django/django/commit/ecaba3602837d1e02fe1e961f7d3bf9086453259

Attachments (1)

21366_test.diff (770 bytes) - added by timo 16 months ago.

Download all attachments as: .zip

Change History (2)

Changed 16 months ago by timo

comment:1 Changed 16 months ago by Anssi Kääriäinen <akaariai@…>

  • Resolution set to fixed
  • Status changed from new to closed

In b44d42be6d05e88071844b64c6519223cdd2fa80:

Fixed #21366 -- regression in join promotion logic

The regression was caused by ecaba3602837d1e02fe1e961f7d3bf9086453259
and affected OR connected filters.

Note: See TracTickets for help on using tickets.
Back to Top