#21320 closed Uncategorized (duplicate)

Template debug gives misleading error for exceptions with django.core.urlresolvers.resolve

Reported by: ellisd23@… Owned by: nobody
Component: Template system Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If a path sent to resolve is not found and a Resolver404 error is raised, the template debugger assumes that the path is missing is the current request path, which is not always the case. For instance, my application uses resolve to get a namespace for a path dynamically. This lead to a nonsensical error that listed my urlconf, followed by a request path that was quite clearly in the URLs, saying it was not found.

Change History (2)

comment:1 Changed 23 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Is this related (or a duplicate) of #18373 or #14343?

comment:2 Changed 23 months ago by ellisd23@…

  • Resolution set to duplicate
  • Status changed from new to closed

Yep, looks like it's a duplicate of #18373. Thanks!

Not completely sure if I'm marking it properly when I submit this comment, but I'm attempting it.

Note: See TracTickets for help on using tickets.
Back to Top