#21262 closed Uncategorized (worksforme)

App read only in django-admin

Reported by: enaut.w@… Owned by: nobody
Component: Uncategorized Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hey,

I think I found a problem in Django.

Steps to reproduce:

  1. Create a new project
  2. Setup DB to sqllite
  3. Create an app (models are enough no views needed)
  4. register the models from within models.py to the admin with admin.site.register
  5. syncdb
  6. set DEBUG=False
  7. include that page in an apache server
  8. Go to the admin page and verify that no entries can be added to the models and neither can the existing ones be viewed.
  9. Verify that the code is correct by running runserver or with DEBUG=True

The models file I used for reproduction:

from django.db import models
from django.contrib import admin


class Tesst(models.Model):
     t = models.CharField(max_length=200)
admin.site.register(Tesst)

To clarify Again:
Expected is: An entry in django-admin that has a button to add or edit Tesst entries aswell as a clickable link Tessts that lists all the entries already entered.

Actual result is: An entry in django-admin but no buttons to add or edit. The Tessts "link" is not a link but a black text and not clickable (Looks as if has_change_permission returns False).

The Bug happens only appears when run with:
apache
DEBUG=False

I run Django 1.4.8 and tried it with apache 2.4.6 (Fedora) and 2.2.15 (CentOS) and python 2.7
There are no special apps needed to trigger the bug.

If there is anything in addition to the already provided information please contact me.

Change History (2)

comment:1 in reply to: ↑ description Changed 18 months ago by enaut

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Version changed from 1.4 to 1.5

I created an account :) and I forgot to mention that on the CentOS server I have the most recent django version 1.5.4

comment:2 Changed 18 months ago by aaugustin

  • Resolution set to worksforme
  • Status changed from new to closed

You're reporting that the admin doesn't work at a very basic level. However, there's evidence that it does work as expected on lots of websites, including mine.

I suggest reaching to our support channels to further isolate the issue, and if it turns out to be a bug in Django, open a more specific ticket.

Note: See TracTickets for help on using tickets.
Back to Top