Opened 3 years ago

Closed 3 years ago

#21232 closed Bug (wontfix)

DATABASES ENGINE settings undocumented breaking change from 1.3 to 1.4 (full class path)

Reported by: ddjango@… Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


Up through Django 1.3, the following shortcut worked in DATABASES settings:


'default' : {

'ENGINE': 'sqlite3',
'NAME': 'my.db',
'USER': ,
'HOST': ,



As of DJango 1.4 (tested on 1.4.8), starting the app results in:

django.core.exceptions.ImproperlyConfigured: 'sqlite3' isn't an available database backend.
Try using django.db.backends.sqlite3 instead.

Changing ENGINE to 'django.db.backends.sqlite3' does indeed fix the problem.

However this is not listed anywhere in the 1.4 release notes:

P.S. Our project started in Django 0.9 and has been carried forward one version at a time. Presumably at some point this was the suggested way of doing this, and it's worked up until 1.4. The change is fine, and the error message is helpful, but the release notes need to include this.

Change History (1)

comment:1 Changed 3 years ago by Anssi Kääriäinen

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: wontfix
Status: newclosed

This was mentioned in deprecation timeline ( Unfortunately it isn't always easy to follow all the changes for single release, as backwards incompatible changes contain some of interesting points, deprecation timeline others.

I am going to mark this as wontfix. This is how our deprecation documentation worked for 1.4 release (there might be improvements in later releases), and changing that now for 1.4 isn't going to happen.

Note: See TracTickets for help on using tickets.
Back to Top