Code

Opened 8 years ago

Closed 8 years ago

#2120 closed defect (duplicate)

Poor schema support (PostgreSQL)

Reported by: caffecoder@… Owned by: adrian
Component: Database layer (models, ORM) Version: master
Severity: normal Keywords: schema, postgresql
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Problem with schemas was reported in tickets #1208 and #1051.

In the result was implemented additional django settings named DATABASE_SCHEMAS, but it's no solution for all problems.
Schemas may contains table with the same names, in this case setting search_patch isn't good idea.

I think, right solution for this would be attibute "db_table_schema" in the "Meta" class that should be respect in all SQL queries.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1051.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.