Opened 4 years ago

Closed 4 years ago

#21199 closed Cleanup/optimization (duplicate)

Backends tests trigger PendingDeprecationWarning

Reported by: Erik Romijn Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: eromijn@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The backends tests import from django.db.backends.util, which has been deprecated. When running the test suite with -Wall, this results in a PendingDeprecationWarning being issued. The test should import from django.db.backends.utils - it's drop-in replacement.

Change History (2)

comment:1 Changed 4 years ago by Erik Romijn

Cc: eromijn@… added
Has patch: set

PR in https://github.com/django/django/pull/1693

Other than changing the import, I noticed it was imported in-line in both places - I moved this to the import at the top.

Last edited 4 years ago by Erik Romijn (previous) (diff)

comment:2 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #21187

Note: See TracTickets for help on using tickets.
Back to Top