Opened 5 years ago

Closed 5 years ago

#21168 closed Cleanup/optimization (duplicate)

Paths to Django objects should be easier to find in the documentation

Reported by: Daniele Procida Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Our documentation doesn't always make it obvious where the objects it's talking about are to be found and imported from.

We do it in various different way. Sometimes:

  • it's shown in an import in a code example
  • an object's full dotted path is shown as part of its name
  • it says explicitly at the start of a section where the objects mentioned in it will be found
  • we don't say it at all

I am not sure what would be best, or whether one way could be used explicitly throughout.

Change History (1)

comment:1 Changed 5 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #15396

Note: See TracTickets for help on using tickets.
Back to Top