Opened 2 years ago

Closed 2 years ago

#20851 closed Bug (fixed)

Couldn't build the docs with the latest docutils (0.11)

Reported by: bruno@… Owned by: nobody
Component: Documentation Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


Hi there,

Today I've tried to build the django docs using a fresh virtualenv with only one installed package: Sphinx.

Here is the pip freeze output:


the make html command threw me this error output:

$ make html
sphinx-build -b djangohtml -n -d _build/doctrees   . _build/html
Running Sphinx v1.2b1
loading pickled environment... failed: env version not current
loading intersphinx inventory from
loading intersphinx inventory from
loading intersphinx inventory from
loading intersphinx inventory from
building [djangohtml]: targets for 264 source files that are out of date
updating environment: 264 added, 0 changed, 0 removed
reading sources... [100%] topics/testing/overview                                                                                                     
looking for now-outdated files... none found
pickling environment... done
checking consistency... done
preparing documents... done
writing output... [  2%] faq/install                                                                                                                  
Exception occurred:
  File "/home/novapost/.virtualenvs/DOCS/local/lib/python2.7/site-packages/docutils/writers/html4css1/", line 1559, in depart_table
    self.compact_p = self.context.pop()
IndexError: pop from empty list
The full traceback has been saved in /tmp/sphinx-err-AXWeLA.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <>,
or report them in the tracker at <>. Thanks!
make: *** [html] Erreur 1

After questionning the IRC django channel on Freenode, it happened to be solved using this "trick"

pip uninstall docutils
pip install docutils==0.10

So far, I could build another Sphinx documentation with the previous setup (including docutils==0.11), but I couldn't do it for Django docs.

Looks like Django documentation is incompatible with the latest docutils version. Maybe it has something to do with docutils itself, but I thought it would be valuable to mention it here, in order to give user instructions about this (i.e. install docutils==0.10 in the docs/README file)


Change History (3)

comment:1 Changed 2 years ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Are you using the latest git checkout of Django? I committed a fix for this issue to master, 1.6.x, 1.5.x, and 1.4.x earlier this week. See a3a59a3197d4e03c5c016edc581bfc5f25668bca for the change on master.

comment:2 Changed 2 years ago by bruno@…

I was using the 1.5.1 tag, because that's the version of Django I was using on my project, and I wanted it to be synced with docs for offline use.

comment:3 Changed 2 years ago by timo

  • Resolution set to fixed
  • Status changed from new to closed

Ok, I'll mark this as fixed then, thanks!

Note: See TracTickets for help on using tickets.
Back to Top