#20736 closed Bug (duplicate)

Uploaded file in previous step form is lost when user navigates to previous page in Django1.4 FormWizard

Reported by: pravasi Owned by: nobody
Component: contrib.formtools Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

All other fields retains the user entered data but an uploaded file in the FileField gets lost when user navigates to previous page I tried using SessionWizardView and NamedUrlSessionWizardView.The required field validation fails.If it is a saved instance (instance of FieldFile ) being edited ,then the field remains populated.To me it looked like the storage.current_step is not getting updated with wizard_goto_step and hence the storage.get_step_files is not getting uploaded files for the previous step but the ones for the current step. This issue was also raised at http://stackoverflow.com/questions/10597021/formwizard-and-filefields-django-1-4

Change History (2)

comment:1 Changed 20 months ago by pravasi

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Uploaded file in previous step form is lost when user navigates to previous page in Django1.4 to Uploaded file in previous step form is lost when user navigates to previous page in Django1.4 FormWizard

comment:2 Changed 20 months ago by claudep

  • Component changed from Forms to contrib.formtools
  • Resolution set to duplicate
  • Status changed from new to closed

Seems to be a duplicate of #7808.

Note: See TracTickets for help on using tickets.
Back to Top