Opened 2 years ago

Closed 2 years ago

#20728 closed Bug (duplicate)

name field on auth_permission too short

Reported by: pvilas@… Owned by: nobody
Component: contrib.auth Version: 1.5
Severity: Normal Keywords: auth_permission, name
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If the verbose_name of the table is over 80 characters the syncdb command will silently fail.

The name field on auth_permissions table is too short to store if verbose_name are that long, so it doesn't update and you cannot assign permissions.

The obvious workaround is to manually change the field length.

Change History (1)

comment:1 Changed 2 years ago by charettes

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8162.

Note: See TracTickets for help on using tickets.
Back to Top