Opened 2 years ago

Closed 2 years ago

#20595 closed Bug (fixed)

Bug in documentation for class based views

Reported by: crazycasta Owned by: nobody
Component: Documentation Version: 1.5
Severity: Normal Keywords:
Cc: bmispelon@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

At https://docs.djangoproject.com/en/1.5/topics/class-based-views/intro/ the example given has an import from django.views.base instead of the (correct) django.views.generic.base.

Change History (3)

comment:1 Changed 2 years ago by bmispelon

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Note that this was fixed in the master branch (with commit bd68f701b1867e0a9cf17d7f0948ba493d11b7e5) but the issue is still present on the 1.5 branch.

comment:2 Changed 2 years ago by bmispelon

  • Cc bmispelon@… added
  • Has patch set

comment:3 Changed 2 years ago by Claude Paroz <claude@…>

  • Resolution set to fixed
  • Status changed from new to closed

In e65f0c255940f9f4ae5e3429e59f3d314104e1fc:

[1.5.x] Fixed an erroneous import in example code.

Backport of bd68f701b from master. Fixes #20595.

Note: See TracTickets for help on using tickets.
Back to Top