Opened 2 years ago

Closed 2 years ago

#20544 closed Bug (duplicate)

User don't translate verbose name to pt_BR

Reported by: leonardocostadepaula@… Owned by: nobody
Component: Python 2 Version: 1.5
Severity: Normal Keywords: translate, user
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

The class User() from Auth don't have the verbose_name at the Meta class with _('user').

I don't know why, but that definition on abstract class is looser.

I need to put this code to work with pt_BR:

class User(AbstractUser):

"""
Users within the Django authentication system are represented by this
model.

Username, password and email are required. Other fields are optional.
"""
class Meta:

swappable = 'AUTH_USER_MODEL'
verbose_name = _('user') # That is my new line to work!

Change History (1)

comment:1 Changed 2 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19945.

Note: See TracTickets for help on using tickets.
Back to Top