Opened 2 years ago

Closed 2 years ago

#20526 closed New feature (duplicate)

django admin framework should provide single record detail view

Reported by: hjbcn@… Owned by: nobody
Component: contrib.admin Version: 1.6-alpha-1
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

  1. Similar with the edit view but without input widgets
  2. Customizeable display cell
  3. An action button to go to the edit view

Change History (3)

comment:1 Changed 2 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from django admin framework should provide signle record detail view to django admin framework should provide single record detail view

comment:2 Changed 2 years ago by anonymous

  1. Allow to config list_display_links to go to the detail view or the edit view
  2. Allow to hide some fields
  3. Allow to display FUNCTION_FIELD

by FUNCTION_FIELD I means the function Title

class MA( models.Model ):
  title = models.CharField(max_length=128)

  def Title(self):
    return self.title
  Title.short_description = _("MyTitle")

comment:3 Changed 2 years ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

I think this is a duplicate of #8936.

Note: See TracTickets for help on using tickets.
Back to Top