Opened 4 years ago

Closed 4 years ago

#20469 closed Bug (fixed)

1.3 Doc "views" link from module index broken.

Reported by: danny@… Owned by: nobody
Component: *.djangoproject.com Version: 1.3
Severity: Normal Keywords:
Cc: bmispelon@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

On the documentation page "https://docs.djangoproject.com/en/1.3/py-modindex/#v" the links to views leads to a 404.

Change History (6)

comment:1 Changed 4 years ago by Kevin Brolly

Easy pickings: set
Triage Stage: UnreviewedAccepted

comment:2 Changed 4 years ago by svisser

The link is also broken in the docs for Django 1.4 but no longer in the docs for Django 1.5.

comment:3 Changed 4 years ago by Baptiste Mispelon

Cc: bmispelon@… added

The code used for building the docs can be found there: https://github.com/django/djangoproject.com/blob/master/docs/management/commands/update_docs.py

I've searched a bit and can't find an obvious error that would lead to the issue.

My current suspicion is that some pyc files aren't getting cleaned up between successive builds, leading to nonexistent modules being included in the modindex.

I will try and investigate further.

comment:4 Changed 4 years ago by Baptiste Mispelon

I managed to reproduce the issue on a local install of djangoproject.com.

To fix it, I tried adding a git clean -fdx after that line: https://github.com/django/djangoproject.com/blob/master/docs/management/commands/update_docs.py#L185.

Unfortunately that didn't change anything.

I did confirm however that the issue is not present if one only builds the 1.4 version of the doc (I tested this by deleting all the other "document release" objects in the admin).

My conclusion is that something is leaking between the different builds, but I can't figure out what it is.

comment:5 Changed 4 years ago by Tim Graham

Component: Documentation*.djangoproject.com
Easy pickings: unset
Type: UncategorizedBug

comment:6 Changed 4 years ago by Tim Graham

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top