Opened 2 years ago

Closed 4 months ago

#20380 closed Cleanup/optimization (fixed)

MySQL doesn't support dates below 1000 on Python 3.2

Reported by: aaugustin Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Someday/Maybe
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

An unofficial port of MySQLdb appears to be the only solution to connect to MySQL from Python 3 at this time, see [e81e319f].

Unfortunately, on Python 3.2, this library introduces a regression on #18969.

The corresponding test was marked as an expected failure in this case in [832b4a572].

This commit should be reverted once the bug is fixed in an official MySQL database adapter for Python 3.

Change History (4)

comment:1 Changed 2 years ago by aaugustin

I haven't reported this bug upstream, because I don't even where to report it, given the current fragmentation.

comment:2 Changed 15 months ago by aaugustin

The solution may be #12500: Support for MySQL Connector/Python.

comment:3 Changed 4 months ago by Claude Paroz <claude@…>

In 412066e71e81e899bca63523f239e56138ec9e9d:

Revert "Marked a test as an expected failure on MySQL and Python 3.2."

This reverts commit 832b4a5722ba6b55e7b17c3bac6614ecca9aa88d.
We officially don't support MySQL on Python 3.2. Refs #20380.

comment:4 Changed 4 months ago by claudep

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top