Opened 2 years ago

Closed 2 years ago

#20268 closed Bug (fixed)

[code.djangoproject.com] Highlighting of core devs is broken if a user has a non-ascii name

Reported by: bmispelon Owned by: nobody
Component: *.djangoproject.com Version:
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

This is caused by a javascript regexp using \w which doesn't work on non-ascii characters.

I wrote a simple fix there (with some more details about the issue): https://github.com/django/code.djangoproject.com/pull/5

Change History (2)

comment:1 Changed 2 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 2 years ago by bmispelon

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top