Code

#20239 closed Uncategorized (duplicate)

Clarify 404 handling when DEBUG = FALSE in tutorial

Reported by: JamesDomingo Owned by: nobody
Component: Documentation Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The section titled
Write a 404 (page not found) view
in the tutorial for version 1.5 needs to clarify what happens when the DEBUG setting is FALSE.
In version 1.5, the
default value for ALLOWED_HOSTS changed.
If a developer following the tutorial creates a custom 404 template and sets DEBUG to FALSE, she will get a 500 server error.
To see the custom 404 template, she needs to change ALLOWED_HOSTS (e.g., ALLOWED_HOSTS = ['localhost'] ).

Attachments (0)

Change History (1)

comment:1 Changed 15 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19875

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.