Code

#20171 closed Uncategorized (duplicate)

DEBUG and ALLOWED_HOSTS documentation

Reported by: sting606@… Owned by: nobody
Component: Documentation Version: 1.5
Severity: Normal Keywords: documentation, logging
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

documentation under DEBUG should warn that it is required to set ALLOWED_HOSTS when setting DEBUG to False
https://docs.djangoproject.com/en/1.5/ref/settings/#debug

moreover, if ALLOWED_HOSTS is left blank then there is no error reported to httpd log file to explain the 500 http status which was very frustrating for me to figure out what was wrong

Attachments (0)

Change History (3)

comment:1 Changed 13 months ago by gertvdijk

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This has been reported numerous times. At least related are:

comment:2 Changed 13 months ago by anonymous

indeed a duplicate, apologizes

comment:3 Changed 13 months ago by carljm

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, we definitely need some improvement here, still working out exactly which improvement(s). Closing as dupe of #19875.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.