Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20149 closed Bug (needsinfo)

Forgot password email not being correctly translated

Reported by: static Owned by: nobody
Component: contrib.admin Version: 1.5
Severity: Normal Keywords: i18n, templates, admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

Using the password_reset_email.html template in the "contrib.admin.templates.registration" the messages in pt_BR are not being translated (maybe in other languages too).

The first sentence, is always showing in english:
"You're receiving this email because you requested a password reset for your user account at YOUR_SITE."

While all the other sentences are being translated.

Change History (3)

comment:1 Changed 2 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I cannot reproduce this error. Are you sure you are not using a custom template in your project?

comment:2 Changed 2 years ago by claudep

  • Resolution set to needsinfo
  • Status changed from new to closed

We will probably need more information, for example a test case, to investigate further.

comment:3 Changed 2 years ago by static

I made some changes in my code and updated Django to 1.5.1, now it is working (very strange).

I was using in my settings:

LANGUAGE_CODE = 'pt-br'

ugettext = lambda s: s
LANGUAGES = (
    ('pt-br', ugettext('Portuguese')),
    ('en', ugettext('English')),
)
DEFAULT_LANGUAGE = 1

I will keep it closed until it happens again.

Note: See TracTickets for help on using tickets.
Back to Top