Opened 9 years ago

Closed 9 years ago

#2003 closed defect (invalid)

ManyToManyField(SomeModel, blank=True, null=True) does not work

Reported by: anonymous Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have a ManyToManyField that I want to be able to leave blank but if I do that I get this error:

"instance needs to have a primary key value before a many-to-many relationship can be used"

I only get that error in the AdminCP though.

Change History (1)

comment:1 Changed 9 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

Sorry, the error was caused by a problem in my "pre save" trigger. Ignore

Note: See TracTickets for help on using tickets.
Back to Top