Opened 2 years ago

Closed 2 years ago

#20001 closed New feature (duplicate)

BigAutoField for Django 1.5 (patch included)

Reported by: jim@… Owned by: nobody
Component: Database layer (models, ORM) Version: 1.5
Severity: Normal Keywords: BigAutoField
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

This week we upgraded to from 1.3 -> 1.5, and discovered BigAutoField was not yet included in Django. I know this issue has been referenced in a number of tickets over the years. In Django 1.3, we went with the mmcnickle approach discussed in ticket 14286 (https://code.djangoproject.com/ticket/14286), but found this difficult to merge into 1.5.

This time, we went with the approach approach suggested by pzinovkin in ticket 56 (https://code.djangoproject.com/attachment/ticket/56/56_bigint.diff). It required tweaking to get it to work cleanly with 1.5

Attached are patches derived from a git clone this morning.

Attachments (1)

bigauto.diff (9.2 KB) - added by jim@… 2 years ago.
BigAutoField patch file.

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by jim@…

BigAutoField patch file.

comment:1 Changed 2 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14286; can you please add the patch over there instead?

Note: See TracTickets for help on using tickets.
Back to Top